ATI wawawouuummmm

Le tuning X11 peut parfois s’avérer pénible, surtout lorsque l’on constate des résultats étranges tels de des trainées de fenêtres sur l’écran, des pixels clignotants, ou encore que ce !@#!@#!@# de DRI refuse de prendre en charge votre carte graphique.
Ainsi, je vous livre en pâture ce fichier /etc/X11/xorg.conf qui me permet de faire tourner une ATI Radeon 3000 (0x9616, carte intégrée à ma station de travail à ${DAYJOB}) sous NetBSD 6.0_BETA2 et son tout nouveau Xorg 1.10.3:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/X11R7/lib/modules"
    FontPath     "/usr/X11R7/lib/X11/fonts/misc/"
    FontPath     "/usr/X11R7/lib/X11/fonts/TTF/"
    FontPath     "/usr/X11R7/lib/X11/fonts/Type1/"
    FontPath     "/usr/X11R7/lib/X11/fonts/75dpi/"
    FontPath     "/usr/X11R7/lib/X11/fonts/100dpi/"
        FontPath     "/usr/pkg/lib/X11/fonts/TTF/"
        FontPath     "/usr/X11R7/lib/X11/fonts/Type1/"
EndSection

Section "Module"
    Load  "dbe"
    Load  "dri"
    Load  "dri2"
    Load  "extmod"
    Load  "glx"
    Load  "record"
    Load  "shadow"
    Load  "freetype"
    Load  "type1"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
        Option      "XkbRules" "xorg"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
        Option      "XkbLayout" "euro"
        Option      "XkbOptions" "compose:ralt"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "wsmouse"
    Option        "Device" "/dev/wsmouse"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        Option     "AccelDFS" "true"
        Option     "AccelMethod" "EXA"
        Option     "DRI"
    Identifier  "Card0"
    Driver      "radeon"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        # Deux ecrans de 1920x1080
        Virtual 3840 1080
        Depth     24
    EndSubSection
EndSection

Section "DRI"
        Mode 0666
EndSection

Section "Extensions"
        Option "Composite" "Enable"
EndSection

On s’assure que tous ces petits gadgets sont effectivement fonctionnels via 1. les messages du noyau concernant le drm:

info: [drm] Setting GART location based on new memory map
info: [drm] Loading RS780 Microcode
info: [drm] Resetting GPU
info: [drm] writeback test succeeded in 1 usecs
radeondrm0: interrupting at ioapic0 pin 18

Et 2. les informations fournies par le fichier /var/log/Xorg.0.log

[   181.985] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[   181.985] (II) AIGLX: enabled GLX_SGI_make_current_read
[   181.985] (II) AIGLX: enabled GLX_texture_from_pixmap with driver support
[   181.986] (II) AIGLX: Loaded and initialized /usr/X11R7/lib/modules/dri/r600_dri.so
[   181.986] (II) GLX: Initialized DRI GL provider for screen 0

C’est qui qui va faire des zuip-zuip hein ?
[tags]NetBSD,6.0,radeon,Xorg[/tags]